WooCommerce atualização

WooCommerce 2.1 e erros com plugins de pagamento e Correios

A cada nova versão do WooCommerce torna-se necessária a atualização dos plugins de pagamento e também os de entrega. Porém, algumas vezes você pode se esquecer de atualizar o plugin e isto fatalmente irá gerar um erro na sua loja virtual. Veja como resolver.

Antes de atualizar o WooCommerce certifique-se de que você pode baixar a versão mais recente do plugin de pagamento. Vamos levar em consideração que você esteja utilizando o plugin WooCommerce PagSeguro para receber pagamentos via PagSeguro. Para evitar erros, atualmente este plugin encontra-se na versão 1.3 compatível com WooCommerce 2.1 e WordPress 3.8

Atualizar plugin

Você pode atualizar plugins enviando os arquivos do mesmo para o servidor FTP da sua loja e também pode fazer isso utilizando o menu de atualização do WordPress (quando disponível). Se você não sabe como atualizar seus plugins siga estas instruções sobre como atualizar plugins WooCommerce.

Erros comuns

Na versão atual do WooCommerce o erro mais comum que você pode encontrar é o de incompatibilidade com o sistema de logs e notificações. Veja exemplos de mensagens de erros:

Em plugins de pagamento

Notice: Woocommerce->add_error está obsoleto desde a versão 2.1! Use wc_add_notice em seu lugar…

Notice: WC_Shortcode_Checkout->output foi chamado com um argumento que está obsoleto desde a versão 2.1!…

Em plugins de entrega e frete (Correios)

Warning: array_intersect() [function.array-intersect]: Argument #1 is not an array in…

Warning: in_array() expects parameter 2 to be array, null given in…

Estou tendo estes problemas no meu site

Para resolver basta seguir as instruções sobre como atualizar seus plugins (apresentadas no inicio deste texto), se precisar de ajuda entre em contato com o atendimento de suporte.

Um comentário sobre “WooCommerce 2.1 e erros com plugins de pagamento e Correios”

  1. Ola pessoal, gostaria de saber como resolver um bug que acontece qd eu instalo o woocommerce, pq a tela de admin do wordpress fica toda branca, alguem podeia me dar um help???

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *